สวัสดีค่ะ มีปัญหาเรื่อง blynk ไม่ทำงาน ช่วยหน่อยนะคะ มือใหม่ค่ะ

ลองอัปโหลดลง esp8266 แล้วค่ะ แต่ตัว blynk มันขึ้นสถานะว่า offline ค่ะ แต่พอเสียบสาย usb กับตัว esp8266 แล้ว มันก้ขึ้นว่าออนไลน์ค่ะ แต่เหมือนตัวใน blynk มันไม่ขึ้นค่าเซนเซอร์ให้เลยค่ะ หนูเสียบ adapter ไปแล้วด้วยค่ะ
อีกปัญหานึงค่ะ คือ ตัวเซนเซอร์วัดความชื้นในดิน รอบแรกไฟที่ตัวเซนเซอร์มันทำงานค่ะ แต่พอ รอบ2แล้วก้อีกหลายๆรอบมันก้ไม่ติดแล้วค่ะ

#define BLYNK_PRINT Serial    
#include <BlynkSimpleEsp8266.h>
#include <ESP8266WiFi.h> // ดาวน์โหลด ไลบรารี่ที่ https://github.com/blynkkk/blynk-library
#include <SimpleTimer.h> // ดาวน์โหลด ไลบรารี่ ที่ https://github.com/jfturcot/SimpleTimer
#include <DHT.h> // ดาวน์โหลด ไลบรารี่ที่ https://github.com/adafruit/DHT-sensor-library
#include <DHT_U.h>

char auth[] = "wJBWmvP8rffn8Aywt51xsGyPBj5Io6FG"; // ใช้ Token ที่คัดลอกจากแอพเรามาวางแทน
char pass[] = "0818624984"; // กรอกรหัส WIFI แทนนะครับ
char ssid[] = "TOR-wifi 2.4Ghz"; //กรอกชื่อ WIFI ที่ต้องการให้ ESP8266 เชื่อมต่อ

#define DHTPIN 2
#define DHTTYPE DHT11
#define pump 16

DHT dht(DHTPIN, DHTTYPE);
SimpleTimer timer;

void sendSensor()
{
  float h = dht.readHumidity();
  float t = dht.readTemperature();

  if (isnan(h) || isnan(t)) {
    Serial.println("Failed to read from DHT sensor!");
    return;
  }
  Blynk.virtualWrite(V5, h);
  Blynk.virtualWrite(V6, t);
}

void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, ssid, pass);
  dht.begin();
  timer.setInterval(1000L, sendSensor);
  pinMode(pump, OUTPUT);
}

void loop()
{
  Blynk.run();
  timer.run();
}

BLYNK_WRITE(V0)
{
  if (param[0])
    digitalWrite(pump, HIGH);
  else
    digitalWrite(pump, LOW);
}

แคป serial มาดูหน่อย

แบบนี้มันไม่ offline นะครับ

ถ่ายการต่อเซนเซอร์มาดูด้วย

อันนี้หน้า blynk ค่ะ

ภาพขึ้นมั้ยคะ

ต้องมี R ต่อด้วยครับลองดู

ได้ค่ะ ต่อแล้วจะมาอัพเดตทีนะคะ

ต่อ R แล้วค่ะ ยังขึ้นเหมือนเดิมเลย

ไม่แน่ใจว่าหนูต่อวงจรตรงกับที่เขียนโค้ดมั้ยอะค่ะ

ต่อผิดรึป่าวครับ เขียวมันไฟไม่ใช่หรอ เราไปเสียบกราวเฉย

อ๋อ อันนี้สลับสายมาเป็นไฟแล้วค่ะ 3V

มันยังขึ้นว่าไม่พบเหมือนเดิมค่ะ

ถ่ายภาพล่าสุดมาดูหน่อยครับ

เรียบร้อยค่ะ

ต่อ r ไม่ถูกต้องครับ

ต้องเอาไปต่อในบอร์ดใช่มั้ยคะ